[Troubleshooting] VLAN

Soal :
Pastikan pc yang vlannya sama bisa test ping

Advertisements

Untuk troubleshooting kali ini terkait VLAN, dengan soal “Pastikan PC yang vlan nya sama bisa test PING”

Sebelumnya Download terlebih dahulu file .pkt disini.

TestIDN1
Ticket 1 – VLAN

Alokasi IP Address :

PC 0 : 10.10.10.1/24
PC 1 : 20.20.20.1/24
PC2 : 10.10.10.2/24
PC 3 : 20.20.20.2/24

Group VLAN :

VLAN 10 : PC 0 & PC 2
VLAN 20 : PC 1 & PC 3

Konfigurasi pada Switch0

[ Sudah benar – Tidak perlu dimodifikasi konfigurasinya]

Konfigurasi pada Switch1 [SW2], Show Running-Config

Current configuration : 1152 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 20
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Show Vlan

SW2#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
100  VLAN0100                         active    Fa0/3
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Jawaban :

  • Dari Konfigurasi awal tersebut interface FastEthernet0/3 masuk ke VLAN 100 mode access, seharusnya interface FastEthernet0/3 digunakan sebagai trunking vlan 10 dan 20. Assign interface FastEthernet0/3 sebagai trunking seperti berikut :
    SW2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    SW2(config)#int f0/3
    SW2(config-if)#no switchport access vlan 100
    SW2(config-if)#no switchport mode access
    SW2(config-if)#switchport mode trunk
    SW2(config-if)#switchport trunk allowed vlan 10,20
  • Test Ping dari PC 0 ke PC 2 dan PC 1 ke PC 3
    PC0>ping 10.10.10.2
    
    Pinging 10.10.10.2 with 32 bytes of data:
    
    Reply from 10.10.10.2: bytes=32 time=0ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=1ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=0ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=0ms TTL=128
    
    Ping statistics for 10.10.10.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    
    PC1>ping 20.20.20.2
    
    Pinging 20.20.20.2 with 32 bytes of data:
    
    Reply from 20.20.20.2: bytes=32 time=1ms TTL=128
    Reply from 20.20.20.2: bytes=32 time=0ms TTL=128
    Reply from 20.20.20.2: bytes=32 time=0ms TTL=128
    Reply from 20.20.20.2: bytes=32 time=0ms TTL=128
    
    Ping statistics for 20.20.20.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms

[Troubleshooting] VLAN SELESAI

Author: admin@khsnndzf

Good People

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s