[Troubleshooting] Inter-VLAN Routing menggunakan Switch Layer 3

PC antar vlan bisa saling komunikasi menggunakan switch layer 3

Advertisements

Just create interface VLAN that is used as client gateway, assign IP address appropriate witch VLAN prefix as client gateway. Activate routing with ‘ip routing’ command.

Troubleshooting berikut ini akan memecahkan masalah bagaimana PC antar vlan bisa saling komunikasi menggunakan switch layer 3. Untuk file Ticket 3.pkt bisa download disini.

TestIDN3.JPG
Ticket 3- InterVLAN Routing

Alokasi IP Address :
– PC 0 : 10.10.10.10/24 gw 10.10.10.1
– PC 1 : 10.10.10.11/24 gw 10.10.10.1
– PC 2 : 20.20.20.10/24 gw 20.20.20.1
– PC 3 : 20.20.20.11/24 gw 20.20.20.1

Alokasi VLAN :
– VLAN 10  : PC0 & PC1
– VLAN 20  : PC2 & PC3

Checklis Konfigurasi yang sudah sesuai (tidak perlu dirubah):
– Semua PC sudah sesuai alokasi IP Addressnya

Konfigurasi yang belum sesuai :
– Switch L3, show running-config

Current configuration : 1581 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.10.10.1 255.255.255.0
shutdown
!
interface Vlan20
ip address 20.20.20.1 255.255.255.0
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

– Switch L3, show vlan

Switch#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------

Langkah Perbaikan :
– Hanya bermain di SwitchMultiLayer (Switch L3), terlihat interface VLAN 10 & Interface VLAN 20 shutdown dan di vlan database belum dibuat vlan 10 & vlan 20 kemudian Untuk menghubungkan atar vlan pada switch L3 perlu ditambahkan perintah ‘ip routing’ pada global configuration berikut command perbaikannya :

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config)#no shutdown
Switch(config)#interface vlan 20
Switch(config)#no shutdown
Switch(config)#ip routing

– Verifikasi Test ping dari PC 0 ke PC 2 dan PC 1 ke PC 3

PC0>ping 20.20.20.10
Pinging 20.20.20.10 with 32 bytes of data:

Reply from 20.20.20.10: bytes=32 time=0ms TTL=127
Reply from 20.20.20.10: bytes=32 time=0ms TTL=127
Reply from 20.20.20.10: bytes=32 time=0ms TTL=127
Reply from 20.20.20.10: bytes=32 time=0ms TTL=127
Ping statistics for 20.20.20.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

PC1>ping 20.20.20.11
Pinging 20.20.20.11 with 32 bytes of data:

Reply from 20.20.20.11: bytes=32 time=1ms TTL=127
Reply from 20.20.20.11: bytes=32 time=0ms TTL=127
Reply from 20.20.20.11: bytes=32 time=0ms TTL=127
Reply from 20.20.20.11: bytes=32 time=0ms TTL=127

Ping statistics for 20.20.20.11:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

[Troubleshooting] Inter-VLAN Routing menggunakan Switch Layer 3 SELESAI

Author: admin@khsnndzf

Good People

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s