[Troubleshooting] Router on a Stick

Soal : Pastikan PC beda vlan dapat melakukan ping ke lain vlan dengan sukses.

Advertisements

To create router on the stick we must create sub-interface in router to assign multiple IP address with different VLAN, each ip is used as client gateway.
Set sub interface with encapsulation dot1q.
Assign IP address appropriate with VLAN prefix.

Untuk Troubleshooting tentang Router on a Stick kali ini memecahkan masalah, bagaimana PC yang beda VLAN bisa saling komunikasi. File Ticket 2.pkt download disini.

TestIDN2
Ticket 2 – Router on a Stick

Alokasi IP Address :
– PC 0 : 10.10.10.1/24 gw 10.10.10.254
– PC 2 : 10.10.10.2/24 gw 10.10.10.254
– PC 1 : 20.20.20.1/24 gw 20.20.20.254
– PC 3 : 20.20.20.2/24 gw 20.20.20.254

Alokasi VLAN :
– VLAN 10  : PC0 & PC2
– VLAN 20  : PC1 & PC3

Checklis Konfigurasi yang sudah sesuai (tidak perlu dirubah):
– Semua PC sudah sesuai alokasi IP Addressnya
– Switch0 [SW1] sudah sesuai

Konfigurasi yang belum sesuai :

Switch1 [SW2], Cek running-config

SW2#sh run
Building configuration...

Current configuration : 1147 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown

!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end


Router1 [Router], cek running-config

Current configuration : 730 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.254 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 200
ip address 20.20.20.245 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Langkah Perbaikan :
– Rubah konfigurasi vlan pada switch1 [SW2], karena konfigurasi vlan pada interface FastEthernetf0/1 dengan FastEthernetf0/2 nya berbeda dengan gambar yang diinginkan. Berikut command perbaikannya :

SW2(config)#int f0/1
SW2(config-if)#no switchport access vlan 20
SW2(config-if)#switchport access vlan 10
SW2(config-if)#int f0/2
SW2(config-if)#no switchport access vlan 10
SW2(config-if)#switchport access vlan 20

– Rubah konfigurasi pada interface FastEthernetf0/0.20 karena penulisan encapsulation salah (200) seharusnya adalah dot1Q 20 (vlan 20) dan IP Addressnya juga salah (20.20.20.245) seharusnya adalah 20.20.20.254

Router(config)#interface FastEthernet0/0.20
Router(config-subif)#no ip address
Router(config-subif)#no encapsulation dot1Q 200
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 20.20.20.254 255.255.255.0

– Verifikasi Test ping dari PC0 ke PC1 dan PC2 ke PC3 (beda VLAN)

PC0>ping 20.20.20.1
Pinging 20.20.20.1 with 32 bytes of data:
Reply from 20.20.20.1: bytes=32 time=0ms TTL=127
Reply from 20.20.20.1: bytes=32 time=0ms TTL=127
Reply from 20.20.20.1: bytes=32 time=0ms TTL=127
Reply from 20.20.20.1: bytes=32 time=0ms TTL=127

Ping statistics for 20.20.20.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

PC2>ping 20.20.20.2
Pinging 20.20.20.2 with 32 bytes of data:

Reply from 20.20.20.2: bytes=32 time=0ms TTL=127
Reply from 20.20.20.2: bytes=32 time=1ms TTL=127
Reply from 20.20.20.2: bytes=32 time=0ms TTL=127
Reply from 20.20.20.2: bytes=32 time=0ms TTL=127
Ping statistics for 20.20.20.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

[Troubleshooting] Router on a Stick SELESAI

Author: admin@khsnndzf

Good People

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s