[Troubleshooting-4] Virtual Trunking Protocol (VTP)

Pastikan PC0 bisa komunikasi dengan PC1 yang melewati 3 switch dengan vtp

Advertisements

VTP is Cisco proprietry protocol that propagates the database of VLAN on the whole local area network.
VTP carries VLAN information to all the switches in a VTP domain.
VTP advertisement can be sent over ISL also 802.1Q.

Each Catalyst Familiy Switch advertises the following on it’s trunk ports :
– Management domain
– Configuration revision number
– Known VLANs and their specific parameter

There are three main parameter of VTP :
– VTP mode
– VTP domain
– VTP password (optional)

There are three types of VTP :
– Server, In VTP server mode, you can create, modify and delet VLAN. VTP server advertise their VLAN configuration to other switch with same VTP domain. VTP server is default mode.
– Client, VTP client beave the same way as VTP servers, but you cannot create, cange or delete VLAN on a VTP client.
– Transparent, VTP trasparent switch do not participate in n VTP. So, VTP transparent switch does not advertise its VLAN configuration

Troubleshooting kali ini akan membahas tentang Virtual Trunking Protocol (VTP), agar lebih mudah dalam langkah lab nya silahkan download file Ticket 4.pkt disini.

Alokasi IP Address :
– PC 0 : 10.10.10.1/24
– PC 1 : 10.10.10.2/24

Alokasi VLAN :
– VLAN 10 : PC 0 dan PC 1

Checklis Konfigurasi yang sudah sesuai (tidak perlu dirubah):
– Semua PC sudah sesuai alokasi IP Addressnya

Checklis Konfigurasi yang belum sesuai :
– Switch0 [SW0], show running-config

Current configuration : 1408 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW0
!
no ip domain-lookup
!
vtp domain IDN
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree portfast default
!
vlan 10
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport port-security violation protect
spanning-tree portfast
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
spanning-tree portfast
!
interface FastEthernet0/4
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

– Switch0 [SW0], show vlan

SW0#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
10 VLAN0010 active Fa0/1
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

– Switch0 [SW0], show vtp status

SW0#sh vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 6
VTP Operating Mode : Transparent
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE0 0xFC 0xAE 0xA3 0x09 0xA2 0xAD 0x06
Configuration last modified by 0.0.0.0 at 3-1-93 00:04:55

– Switch1 [SW1], show running-config

Building configuration...

Current configuration : 1109 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
no ip domain-lookup
!
vtp domain IDN
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree portfast default
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

– Switch1 [SW1], show vlan

SW1#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

– Switch1 [SW1], show vtp status

SW1#sh vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
VTP Operating Mode : Transparent
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE0 0xFC 0xAE 0xA3 0x09 0xA2 0xAD 0x06
Configuration last modified by 0.0.0.0 at 3-1-93 00:04:55

– Switch2 [SW2], show running-config

SW2#sh run
Building configuration...

Current configuration : 1171 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
no ip domain-lookup
!
vtp domain IDN
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree portfast default
!
vlan 10
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!

!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

– Switch2 [SW2], show vlan

SW2#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
10 VLAN0010 active Fa0/2 
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

– Switch2 [SW2], show vtp status

SW2#sh vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 6
VTP Operating Mode : Transparent
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xC3 0x8F 0x4F 0x72 0xAA 0x54 0x5C 0x70
Configuration last modified by 0.0.0.0 at 3-1-93 00:06:13

Langkah Perbaikan :
– Dari ketiga konfigurasi switch diatas, semuanya menggunakan vtp mode transparant, perlu diperbaiki untuk salah satunya dibuat mode server dan yang lainnya dibuat mode client. Berikut command perbaikanya :

  • Switch0 [SW0], rubah menjadi vtp mode server dengan menghapus mode sebelumnya secara otomatis/default vtp akan berubah ke mode server
SW0(config)#no vtp mode
Resetting device to VTP SERVER mode.
SW0#sh vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 6
VTP Operating Mode : Server
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE0 0xFC 0xAE 0xA3 0x09 0xA2 0xAD 0x06
Configuration last modified by 0.0.0.0 at 3-1-93 00:04:55
Local updater ID is 0.0.0.0 (no valid interface found)
  • Switch1 [SW1], rubah menjadi vtp mode client kemudian switch akan menerima informasi vlan dari vtp server.
SW1(config)#no vtp mode
Resetting device to VTP SERVER mode.
SW1(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW1(config)#end

SW1#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
10 VLAN0010 active /*Otomatis mendapatkan informasi vlan dari vtp server*/
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0


SW1#sh vtp stat
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 6
VTP Operating Mode : Client
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE0 0xFC 0xAE 0xA3 0x09 0xA2 0xAD 0x06
Configuration last modified by 0.0.0.0 at 3-1-93 00:04:55
  • Switch2[SW2], rubah menjadi vtp mode client
SW2(config)#no vtp mode
Resetting device to VTP SERVER mode.
SW2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW2(config)#end
SW2#sh vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 6
VTP Operating Mode : Client
VTP Domain Name : IDN
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xC3 0x8F 0x4F 0x72 0xAA 0x54 0x5C 0x70
Configuration last modified by 0.0.0.0 at 3-1-93 00:06:13
  • Verifikasi test PING dari PC 0 ke PC 1
PC0>ping 10.10.10.2

Pinging 10.10.10.2 with 32 bytes of data:

Reply from 10.10.10.2: bytes=32 time=1ms TTL=128
Reply from 10.10.10.2: bytes=32 time=0ms TTL=128
Reply from 10.10.10.2: bytes=32 time=1ms TTL=128
Reply from 10.10.10.2: bytes=32 time=1ms TTL=128

Ping statistics for 10.10.10.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

[Troubleshooting] Virtual Trunking Protocol (VTP) SELESAI

Source Materi : CCNA ID-Networkers

Author: admin@khsnndzf

Good People

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s