[Troubleshooting-5] Etherchannel LACP

Pastikan PC bisa saling test ping dan menggunakan etherchannel LACP

Advertisements

Introduction about Etherchannel LACP
For create more advance switching redundant technology you can use Etherchannel. With etherchannel you can bundling two or more link with one port-channel interface. Bandwidth will increase x times, where x is the number of links you bundle.

Konsep Etherchannel
Basic Concept Etherchannel

Etherchannel dapat dikonfigurasikan dengan dua hingga delapan active FastEthernet, GigabitEthernet atau TenGigabitEthernet port. Jadi jika menggunakan 8 port bisa menghasilkan kecepatan 800 Mbit/s, 8 Gbit/s atau 80 Gbit/s.

There are protocols about etherchannel in Cisco Catalyst, they are :

  • LACP (Link Aggregation Control Protocol)
  • PAgP (Port Aggregation Protocol)

Untuk troubleshooting ke-5 ini mencoba memecahkan masalah bagaimana PC bisa saling ping dimana PC tersebut melewati 2 switch yang di aktifkan fitur etherchannel LACP. Dan hasil show etherchannel summary seperti berikut :

SW1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------
1      Po1(SU)           LACP   Fa0/2(P) Fa0/3(P) 

Agar lebih mudah dalam belajar, silahkan download Tiket-5.pkt disini.

 

TestIDN5
Topologi Troubleshooting LACP

Alokasi IP Address :
– PC 0 : 10.10.10.1/24
– PC 1 : 10.10.10.2/24

Alokasi VLAN :
– VLAN 10 : PC 0 dan PC 1

Checklis Konfigurasi yang sudah sesuai (tidak perlu dirubah):
– Semua PC sudah sesuai alokasi IP Addressnya

Checklis Konfigurasi yang belum sesuai :
– Switch0 [SW1], show running-config

Building configuration...

Current configuration : 1212 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
!
spanning-tree mode pvst
spanning-tree portfast default
!
interface FastEthernet0/1
 switchport access vlan 18
 switchport mode access
!
interface FastEthernet0/2
 channel-group 1 mode passive
 switchport mode trunk
!
interface FastEthernet0/3
 channel-group 1 mode passive
 switchport mode trunk
!
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
end

– Switch1 [SW2], show running-config

Building configuration...

Current configuration : 1212 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
spanning-tree mode pvst
spanning-tree portfast default
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 channel-group 1 mode passive
 switchport mode trunk
!
interface FastEthernet0/3
 channel-group 1 mode passive
 switchport mode trunk
!
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
end

Langkah Perbaikan :

  • Switch0 [SW1], vlan yang di assign pada FastEthernet0/1 salah, harusnya vlan 10, dan yang diinginkan pada soal adalah port FastEthernet0/2-3 adalah Protocol LACP Port nya P in-PortChanel maka interface tersebut dibuat mode active keduanya. Berikut commandnya :
    SW1#conf t
    SW1(config)#int f0/1
    SW1(config-if)#switchport access vlan 10
    SW1(config-if)#int range f0/2-3
    SW1(config-if-range)#channel-group 1 mode active
    SW1(config-if-range)#end
    SW1#sh etherchannel summary
    Flags: D - down P - in port-channel
     I - stand-alone s - suspended
     H - Hot-standby (LACP only)
     R - Layer3 S - Layer2
     U - in use f - failed to allocate aggregator
     u - unsuitable for bundling
     w - waiting to be aggregated
     d - default port
    
    Number of channel-groups in use: 1
    Number of aggregators: 1
    
    Group Port-channel Protocol Ports
    ------+-------------+-----------+----------------------------
    1 Po1(SU) LACP Fa0/2(P) Fa0/3(P)
  • Switch1 [SW2], Protocol LACP Port nya P in-PortChanel maka interface tersebut dibuat mode active keduanya. Berikut commandnya :
    SW2#conf t
    SW2(config)#int range f0/2-3
    SW2(config-if-range)#channel-group 1 mode active
    SW2(config-if-range)#end
    SW2#show etherchannel summary
    Flags: D - down P - in port-channel
     I - stand-alone s - suspended
     H - Hot-standby (LACP only)
     R - Layer3 S - Layer2
     U - in use f - failed to allocate aggregator
     u - unsuitable for bundling
     w - waiting to be aggregated
     d - default port
    
    Number of channel-groups in use: 1
    Number of aggregators: 1
    
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------
    1 Po1(SU) LACP Fa0/2(P) Fa0/3(P)
  • Verifikasi, test ping dari PC0 ke PC 1 :
    PC0>ping 10.10.10.2
    
    Pinging 10.10.10.2 with 32 bytes of data:
    
    Reply from 10.10.10.2: bytes=32 time=55ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=0ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=1ms TTL=128
    Reply from 10.10.10.2: bytes=32 time=1ms TTL=128
    
    Ping statistics for 10.10.10.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 55ms, Average = 14ms

[Troubleshooting-5] Etherchannel LACP SELESAI 🙂

Source Materi : CCNA ID-Networkers

Author: admin@khsnndzf

Good People

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s