how to ; clear show interface counter

Biasanya ada case ping dari gateway ke salah satu host mengalami intermitten (packet loss), salah satunya penyebabnya bad connector / cable. setelah diperbaiki connector / cable perlu di clear counter interface tersebut, agar memudahkan dalam monitoring pasca perbaikannya.

Berikut contoh error counter yang terdapat pada salah satu interface :

#sh int GigabitEthernet2/48 | i CRC 
 38207684 input errors, 6997944 CRC, 0 frame, 0 overrun, 0 ignored

Sebelum di perbaiki connector/cable nya lakukan clear counter terlebih dahulu

#clear counters GigabitEthernet2/48
Clear "show interface" counters on this interface [confirm]
#sh int GigabitEthernet2/48 | i CRC
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

Monitoring link dengan lewatkan trafik di interface tersebut, pastikan angka tetap 0. jika masih problem silahkan dicoba pindah ke port yang lain.

Advertisements

Cara memasang card WS-X6704-10GE pada cisco 7600 series routers

Untuk memasang card ini harus dipastikan bahwa supply power router masih tercukupi, adapun besaran power untuk card ini adalah ±330 Watts. Untuk cek system power available ketik perintah #show power, saran saja: biar enak baca log secara realtime silahkan langsung console router tersebut.

Jangan lupa untuk backup config sebelum eksekusi, untuk antisipasi ketika router problem setelah insert card.

Lepas blank panel dari slot yang masih tersedia pada router, dan masukkan card WS-X6704-10GE dengan hati-hati. Jika ragu silahkan tonton video ini terlebih dahulu

Pada saat bersamaan anda insert card, indikator status dan system pada SUP akan berwarna merah, dan ping ke arah loopback laptop akan RTO ±5 detik jadi jangan panik dulu karena itu tidak mempengaruhi service yang jalan, biasanya terdapat log berikut :

%C6KERRDETECT-SP-4-SWBUSSTALL: The switching bus is experiencing stall for 3 seconds
Problem
The switch reports these error messages:
%C6KERRDETECT-SP-4-SWBUSSTALL: The switching bus is experiencing stall for 3 seconds
%C6KERRDETECT-SP-4-SWBUSSTALL_RECOVERED: The switching bus stall is recovered and data traffic switching continues

Kenapa ? karena berikut :
Basically, if any one module on the system bus hangs then the supervisor detects a timeout and tries to recover on its own. If a module was in the process of being installed then that is a very possible cause of these messages since this can cause a bus stall while the module gets seated into the backplane

Selanjutnya verifikasi apakah card sudah terbaca dengan baik dengan perintah #show module, pastikan card WS-X6704-10GE sudah terbaca sesuai dengan slot nya yaitu slot 4 dan online status nya Pass.

#show module
Mod Ports Card Type                              Model              Serial No.
— —– ————————————– —————— ———–
4    4  CEF720 4 port 10-Gigabit Ethernet      WS-X6704-10GE      SAL12383K5T

Mod  Online Diag Status
—- ——————-
1  Pass
2  Pass
  4  Pass

Setelah card terbaca dan status online pass, artinya card sudah bisa digunakan, insert xenpak sesuai kebutuhan di port 1 – 4.

Plug kabel single mode dengan konektor SC pada port xenpak yang terpasang,

Dan terahir test ping P2P untuk memastikan port berjalan normal.

20170421_004658

20170421_0141581

🙂

Konfigurasi Dasar Router Switch Cisco untuk Service Dedicated Internet

cisco

Cara konfigurasi dasar router dan switch cisco untuk service dedicated internet (dapat ip public) dari ISP, dasar dalam arti disini akan bahas konfigurasi router cisco sebagai router NAT saja. Berikut asumsi alokasi IP Address dari topologi diatas :

  • IP Gateway ISP 192.253.20.57/29
  • IP Router Customer 192.253.20.58/29
  • IP Untuk NAT Customer 192.253.20.59/29
  • IP LAN Customer 192.168.10.0/24

Berikut konfigurasi disisi Router Cisco Customer :

*** Konfigurasi IP WAN ***
interface GigabitEthernet0/1
 description *** Link To Provider ***
 ip address 192.253.20.58 255.255.255.248
 ip nat outside

*** Konfigurasi IP LAN ***
interface GigabitEthernet0/0
 description *** Link to Internal ***
 ip address 192.168.10.1 255.255.255.0
 ip nat inside

*** Buat DHCP pool IP LAN ***
ip dhcp pool biznet
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 dns-server 203.142.82.222 203.142.84.222
 ip dhcp excluded-address 192.168.10.255

*** Buat access-list untuk IP LAN ***
access-list 1 permit 192.168.10.0 0.0.0.255

*** Buat NAT untuk IP LAN ***
ip nat pool biznet 192.253.20.59 192.253.20.59 netmask 255.255.255.248
ip nat inside source list 1 pool biznet overload

*** Buat static route dengan next-hop IP gateway di ISP ***
ip route 0.0.0.0 0.0.0.0 192.253.20.57 

*** Buat akses untuk remote login Router ***
enable password cisco01

line vty 0 4
 password cisco01
 login

Berikut konfigurasi disisi Switch Cisco Customer :

*** Buat IP Management Switch dari ip LAN ***
interface Vlan1
 ip address 192.168.10.255 255.255.255.0

*** Buat akses untuk remote login switch ***
enable password cisco01

line vty 0 4
 password cisco01
 login

Cek PC-Client sudah dapat ip dhcp client dan bisa ping ke internet :

C:\>ipconfig

Windows IP Configuration
Ethernet adapter Local Area Connection:

 Connection-specific DNS Suffix . :
 IPv4 Address. . . . . . . . . . . : 192.168.10.2
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Default Gateway . . . . . . . . . : 192.168.10.1

PC>ping 8.8.8.8

Pinging 8.8.8.8 with 32 bytes of data:

Reply from 8.8.8.8: bytes=32 time=1ms TTL=254
Reply from 8.8.8.8: bytes=32 time=0ms TTL=254
Reply from 8.8.8.8: bytes=32 time=0ms TTL=254
Reply from 8.8.8.8: bytes=32 time=16ms TTL=254

Ping statistics for 8.8.8.8:
 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
 Minimum = 0ms, Maximum = 16ms, Average = 4ms

Test remote login ke Router dan Switch dari PC-Client :

PC>telnet 192.168.10.255
Trying 192.168.10.255 ...Open

User Access Verification
Password: 
Switch>enable
Password: 

Switch#show interfaces vlan 1
Vlan1 is up, line protocol is up
 Hardware is CPU Interface, address is 0090.21ca.4d23 (bia 0090.21ca.4d23)
 Internet address is 192.168.10.255/24
 MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 21:40:21, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 1682 packets input, 530955 bytes, 0 no buffer
 Received 0 broadcasts (0 IP multicast)
 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 563859 packets output, 0 bytes, 0 underruns
 0 output errors, 23 interface resets
 0 output buffer failures, 0 output buffers swapped out

PC>telnet 192.168.0.1
Trying 192.168.0.1 ...Open

User Access Verification
Password: 
Router>enable
Password: 

Router#sh int g0/0
GigabitEthernet0/0 is up, line protocol is up (connected)
 Hardware is CN Gigabit Ethernet, address is 0001.c763.7a01 (bia 0001.c763.7a01)
 Description: *** Link to Internal ***
 Internet address is 192.168.10.1/24
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 100Mb/s, media type is RJ45
 output flow-control is unsupported, input flow-control is unsupported
 ARP type: ARPA, ARP Timeout 04:00:00, 
 Last input 00:00:08, output 00:00:05, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0 (size/max/drops); Total output drops: 0
 Queueing strategy: fifo
 Output queue :0/40 (size/max)
 5 minute input rate 29 bits/sec, 0 packets/sec
 5 minute output rate 20 bits/sec, 0 packets/sec
 138 packets input, 7832 bytes, 0 no buffer
 Received 6 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 0 watchdog, 1017 multicast, 0 pause input
 0 input packets with dribble condition detected
 109 packets output, 6715 bytes, 0 underruns
 0 output errors, 0 collisions, 1 interface resets
 0 unknown protocol drops
 0 babbles, 0 late collision, 0 deferred
 0 lost carrier, 0 no carrier
 0 output buffer failures, 0 output buffers swapped out

Sekian Konfigurasi Dasar Router Switch Cisco untuk Service Dedicated Internet 🙂

Cara menghapus log session telnet di cisco

Remote login router cisco paling mudah ya pake telnet. Telnet sering digunakan untuk akses ke router dengan cepat. Telnet biasa diatur oleh seorang admin jaringan dengan maximal session yang akan di allow. Ketika session login habis mungkin karena serangan dari network luar (attacker) maka user yang seharusnya bisa masuk akan terputus dan selalu gagal remote login ke router tersebut. Disini clear line vty saja gak ampuh, untuk menghapus session pada remote login dengan telnet.

Biasanya dalam keadaan seperti ini ip management masih bisa di ping namun untuk remote login dengan telnet tidak bisa, solusinya harus di console langsung pada perangkatnya.

Berikut cara clear seasson yg ampuh dengan clear tcp tcb, sebelumnya lakukan show users terlebih dahulu untuk melihat ip address user yang masih nge chace, setelah didapatkan user yg dimaksud lakukan show tcp brief. Pilih local address yg sesuai dengan ip address user yg nge chace sebelumnya dan terahir lakukan clear tcp tcb [index tcb]

#show tcp brief 
TCB Local Address Foreign Address (state)
00526094 x.x.x.x x.x.x.x.55875 TIMEWAIT
007B2F8C x.x.x.x x.x.x.x.62886 ESTAB
007370F4 x.x.x.x x.x.x.x.56058 TIMEWAIT
007340D4 x.x.x.x x.x.x.x.55728 TIMEWAIT

#clear tcp tcb 007B2F8C

Cara Remote Mikrotik di GNS3 Menggunakan Winbox

Pastikan sudah bisa install loopback adapter pada windows, kalau belum bisa cek artikel ini. Juga sudah bisa install mikrotik di GNS3, kalau belum bisa cek artikel ini juga. Secara langsung Router mikrotik tidak bisa direct connected ke loopback laptop, jadi saya menggunakan tambahan hub switch ditengah-tengahnya.
topologi

Continue reading “Cara Remote Mikrotik di GNS3 Menggunakan Winbox”

Cara Install RouterOS Mikrotik di GNS3 Windows

Mau ngoprek mikrotik tapi gak ada routerboard, mending pake simulator saja, GNS andalannya untuk simulator jaringan, pada artikel sebelumnya saya share beberapa file ios cisco untuk ngoprek di GNS3 dimana untuk cisco ios bisa langsung running tanpa perlu diinstall terlebih dahulu, namun untuk mengaktifkan mikrotik sendiri pada GNS3 bisa menggunakan Qemu, kenapa menggunakan Qemu?? untuk kelebihan qemu dibanding yang lainnya misal virtual box silahkan cari sendiri di internet banyak.

Download GNS3 All in One dan Image Mikrotik

Pastikan sudah install GNS3 terlebih dahulu ya, Langsung saja, check it out:

Continue reading “Cara Install RouterOS Mikrotik di GNS3 Windows”

How to Configure Speed and Duplex on Windows 7

Ternyata bukan hanya pada switch atau router manage yang dapat kita atur untuk speed dan duplex pada NIC (Network Interface Card) tetapi di laptop pun bisa kita rubah sesuai keinginan. Kebetulan di laptop pakai driver NIC type Realtek PCIe GBE Family Controller, dimana driver tersebut sudah support 1Gbps, namun saat test koneksi selalu detek hanya 100Mbps, ternyata ada 2 alasan kenapa NIC 1Gbps bisa kedetek 100Mbps bahkan lebih kecil baik Full Duplex maupun Half Duplex diantaranya adalah kualitas kabel dan settingan pada driver NIC nya itu sendiri. Kualitas kabel jelas mempengaruhi untuk segi transmisinya, adapun untuk konfigurasi pada NIC nya bisa mengikuti langkah-langkah berikut : Continue reading “How to Configure Speed and Duplex on Windows 7”